Top-up failure

Hello everyone! I am trying to add funds to my account using a university pre-paid card and every time I try to add funds, I receive an error message at the top right corner of my screen telling me the top-up failed.

I called the bank that issued the card and there are no blocks on the card. Is this a Prolific issue?

I tried paying other ways (using an invoice) but I receive the same message. Unfortunately, I cannot do a wire/bank transfer through my university. I really do not want to resort to another platform. Can someone point me in the right direct to help me resolve this?

Dear Karoline

Welcome to the forum :slight_smile:

This is a problem that has occured from time to time in the past but I am afraid that other than waiting for support ( which can take time in the case of this type of problem) or using an alternative method of payment, I know of no solution.

I think that it is an issue with Prolific or rather with the company that Prolific uses to accept online payments, or rather an incompatibility between that company and your card. There are all sorts of card based, and also individual account based reasons why card payments fail it seems.

I can only suggest/ask, do you have another card?

I am sorry I am unable to help.


Timothy Takemoto
Yamaguchi University

Hi Tim,

Thank you for getting back to me. I do not have another card.

I’ve seen that other solutions have worked for people in the past. For instance, one user mentioned that an authentication/upgrade to their Prolific account resolved the issue. I tried to pay using an invoice but that did not work either.

I have also been in touch with my bank/card company and they said there are no blocks on the card. So I’m not sure which direction to try next.