Getting an error when trying to publish

I’m trying to publish a study “Body attitudes over time.” I have specified all three devices before I hit “publish.” I agree to the stipulations and try to “confirm publish” and then receive the error: “We could not publish the study as you have not selected which devices this study is compatible with. Please select at lease one of desktop, tablet or mobile compatible study options.” (But I had checked all of them!). I go back to the survey page, and they are unchecked. I check them all again and try, but I receive the same error. I think that the checked devices are erased each time. Please assist.

Hello Tracy!

Just to be sure, you’ve selected the filters such that it appears to you like the following?:


And instead, when you click “Publish”, it redirects you to the same block but you see something like this instead?:


I honestly never had such an issue. If it is a bug, I cannot help but the Prolific Team should be able to (@Josh may want to have a look at it).

Let me know if you have any news and in the meantime, welcome to the Forum!

Thanks for your response, Veronica! Yes I had the filters on. I was able to set up a new study and it worked. It must have been a bug in the former study. If it happens again to someone else, I’d recommend to have them set up a new study.